Jump to content

Games get stuck at load screen

Recommended Posts



I have an occulus quest, with Virtual Desktop (VD). I'm running Windows 10 pro, with a Nvidia 1070, 8GB RAM. I'm successfully running Steam VR games through VD with no problems.

Seeing your offer for Viveport, I thought I'd give it a go. Unfortunately, I've tried four games now and feel like giving up 🙂

Westworld - I get the initial menus and when I try and start a game, it just hangs on the loading logo.

Ultrawings - I get the loading logo, music starts then nothing

Rush - It loads and I'm in the aircraft, but my hands are stuck to the floor. I tried to change the bindings, but can't attach the skeleon binding to either hand

Richie's Plank - It runs, but it's choppy at best, even with low graphics settings.

Is there something I'm missing before I sign up for 12 months?


Share this post

Link to post
Share on other sites

Quick update:

Tried this through occulus link

Ultrawings now works, but the other games are exactly the same. Westworld loading icon animates longer before crashing.

Share this post

Link to post
Share on other sites

Please sign in to comment

You need to be a member in order to leave a comment

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...